XJSC Soft Top Loose Bolt

Viewing 2 reply threads
  • Author
    Posts
    • #10919
      Martin Ball
      Participant

      Hi there, I have one Allen Head bolt on my soft top that is loose and just won’t grab anything when I try to tighten it up.  Two photos attached.  Does anyone have any experience with these bolts?  Should there be a secure nut on the body to mate or has a nut fallen off somewhere?  Do you know how I can get to underneath the cover from inside the car to secure this bolt, Many thanks in advance, Martin

      Photo 1164
      Photo 1165

    • #11311
      Norman Thomas
      Participant

      Hi Martin,

      Its no help but I’ve had the same problem – I have a few “loose”. The screws are chromed and always in good condition, but they must screw into something which either rusts or is a captive nut which comes loose or disintegrates over time. Recommend that if the others are OK, unscrew them and lubricate to prevent further deterioration! I’ve not checked to see if you can access these from inside – probably not an easy job.

      Regards,

      Norman.

    • #11383
      Martin Ball
      Participant

      Thanks Norman, it is  impossible (for me) to get up and under to locate the ‘nut’ as such

      What I did notice was that with all my pushing trying to get it to bite the thread on the screw was a bit damaged.  I found a longer bolt and it grabbed nicely and it is secure.  I suspect the thickness of the material was just too much for the screw to grip.

      Anyway, minor issue but fixed so that’s good

      Cheers

      Martin

       

       

       

       

Viewing 2 reply threads
  • You must be logged in to reply to this topic.
Scroll Up