Ignition/battery warning light on VERY bright.

  • This topic has 2 replies, 2 voices, and was last updated 4 years ago by Dave Jones. This post has been viewed 382 times
Viewing 2 reply threads
  • Author
    Posts
    • #3889
      Dave Jones
      Participant

      Hello guys I have a 1985 3.6 Cabriolet & I am having a little starting problem. At cold start the engine turns over great but refuses to tick over. I can keep it going with the pedal & after 3/4 mins all is well. During this time the rev counter does not work??
      After the initial couple of mins all is fine & it will start till it get cold again. Once or twice, while having this trouble the red battery/ignition warning light comes on very very bright but the alternator is charging? Any ideas guys?
      David,
      St Helens.

    • #3896
      Laurence Jones
      Keymaster

      Hi David,

      You don’t mention of the Rev counter starts working again once everything is warm and settled.

      Mine had a similar but different problem – in that mine would over rev until it was warm and then everything seemed to click into place and all would be well again. I believe the issue with mine was the airflow meter on the carb just simply not getting things right.

      Laurence

    • #3909
      Dave Jones
      Participant

      No Laurence, the rev counter starts within 2/3 minutes well before the engine has had time to warm up. Local RAC guy mentioned bad earth or muck on ignition amplifier which is situated over the rad casing. I’ve cleaned & checked this plus changed the 2 small air & petrol sensors? David.

Viewing 2 reply threads
  • You must be logged in to reply to this topic.
Scroll Up